Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tiara Open 454 shutdown
#11
I would bet on the coil going bad. Especially with a crack around it. Coils will work for a bit and then once they get hot will break down and stop working. I had a customers forklift doing the same thing and one of my technicians put 8 hours and quite a few hundred dollars in parts trying to fix it awhile back. I asked him if he had put a spark tester on it and once we did the problem was obvious. Replaced the coil and everything was perfect again.

Always start with the simple things first, usually that's where it will be.
Like Post Reply

#12
(05-13-2019, 07:36 AM)RCKLAW Wrote: This is a long shot: My 1995 454 with fuel injection would not hold rpms and eventually cut out mysteriously - mechanic first thought electrical and then fuel. After trying many fixes - and throwing a ridiculous amount of money at the problem - it turned out to be a defective anti-siphon valve in the fuel tank that prevented fuel from being drawn from the tank.

Hello all

I am having similar issues with my 1995 35 express 8.1 fi. no one can seem to put there finger on it. Port engine,
pumped tanks last year, replaced all filters and installed aux. filters, fresh tune up, new fuel pump, coil good, swapped computer
from other engine and back, ran off starboard tank same issue, I will try the fuel cap thing,

thanks and keep ideas coming
Like Post Reply
#13
When the generator was installed, how was the fuel line run? I believe for a factory install, they have their own fuel connection at the tank.

Was it connected to the fuel system of the motor your having problems with? If so, you could have a loose connection and be sucking air.

Sent from my XT1635-01 using Tapatalk
Like Post Reply
#14
Same problem, about 1800 hours on port, then at 2100 hours on star. Wiring to ignition relay started getting hot and messing with relay. Need wiring redone and new relays.
Both act like fuel problem but not.
Relay would show burn mark on connection, but not at first. Took 2 years to figure out first time.
1999 454 mpi
35 open
Like Post Reply
  




Users browsing this thread:
1 Guest(s)

454 shutdown00