Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tiara Open Crusader 454 XLI issues
#1
Own a 1995 Tiara 3100 open since day 1. Rebuilt the 454 in 2016 at 1000 hours. Now have aproblem with STBD engine, starts, runs and suddenly without any indication shuts off, will not restart for same time, than starts and does the same any thoughts?
Like Post Reply

#2
I have 99; 454 EFI,  any mystery problems I have had has gone to the relay switches, and wiring. Or the distributor shaft. 
Rebuild at 1000, seems pretty low for that.
ISBIB
Like Post Reply
#3
yes its low but they were 20 years old, thinking of ripping them and put 2 yanmar diesels in
Like Post Reply
#4
(01-09-2021, 03:52 PM)TwoToTango Wrote: yes its low but they were 20 years old, thinking of ripping them and put 2 yanmar diesels in

I’ve got 2600 hours. Still going strong, had top ends done at 1500, but it is fresh water.
Yanmars would make it rocket ship.
ISBIB
Like Post Reply
#5
(01-09-2021, 03:22 PM)TwoToTango Wrote: Own a 1995 Tiara 3100 open since day 1. Rebuilt the 454 in 2016 at 1000 hours. Now have aproblem with STBD engine, starts, runs and suddenly without any indication shuts off, will not restart for same time, than starts and does the same any thoughts?
The first thing I would check is electrical from the dash to the motor. My friends 95 37' Silverton Crusader did something similar to what your describing. The "run" wire from the ignition back to the motor had a bad connection and intermittently would shut the motor off and wouldn't restart. Then later would fire right back up. They chased everything on that motor for half the summer before finding it.

Sent from my SM-A505U using Tapatalk

Oh, and my Crusaders are 34 years old, over 4300 hours now. Had a valve job on them back around 2500ish hours. Still purr like kittens...

Sent from my SM-A505U using Tapatalk
Like Post Reply
#6
It may sound silly but you need to get to the root problem. Is it electrical or fuel related. The electrical solutions above sound possible. If it is electrical does heating the engines up have anything to do with it, (you said it would run then quite). I have also witnessed fuel problems for this also. The vent for the fuel tank was plugged by mud dobber wasps. While the fuel was being consumed by running, there was no air venting into the tank. When enough fuel was depleted it created a negative pressure in the tank and the engine would quite. Let it sit for a while, and the air pressure equalizes allowing fuel to flow again and the engine will run.
[-] The following 1 user Likes Redarrow32's post:
Misdirection (01-21-2021)
Like Post Reply
#7
I had a similar problem that took forever to diagnose. Turned out to be a defective anti-siphon valve in the fuel tank serving that engine..
[-] The following 1 user Likes RCKLAW's post:
Misdirection (01-22-2021)
Like Post Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  98 Crusader 454 Port transmission robh19 5 750 11-26-2020, 11:21 AM
Last Post: robh19
  Alternator options 2002 8.1 crusader engines rwshevy 0 222 08-22-2020, 10:31 AM
Last Post: rwshevy
  [Tiara Convertible] 1996 454 Crusader Fuel pump pressure switch seahagbrewing 0 298 06-17-2020, 02:50 PM
Last Post: seahagbrewing
  Crusader 8.1 mpi surges at running speed Betterdays123 7 3,460 01-16-2020, 03:21 PM
Last Post: sluggo
  genny issues any help appreciated sluggo 18 4,308 12-27-2019, 09:08 AM
Last Post: sluggo



Users browsing this thread:
1 Guest(s)

Crusader 454 XLI issues00