Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Troubleshooting raymarine power issues - 2010 3600 Open
#1
Hi everyone-

2010 3600 Open.  

For the first time in 3 years, I can not get navigation electronics (Raymarine e140W + ST70s) to power-up.   DC switch panel does not have a switch for the electronics.  Same with helm circuit breaker - no breakers there.

Does anyone have an idea where to start troubleshooting?  Presumably there are a set of fuses behind the helm but not sure if that's where I should start.  Thanks for the help.
Like Post Reply

#2
Are you sure you checked ALL The breakers?
Like Post Reply
#3
Start at the power cable behind the unit and work backwards from there. If everything else is working, it's not going to be a major issue. Probably an inline fuse or where the power cable connects to the bus bar.
Sans Peur 2003 Tiara 50 Open
Like Post Reply
#4
Closing this out. Donald was spot on. One missed panel switch which I found after hours with the voltmeter in tight quarters. Now I fully understand the wiring and location of the inline fuses.

Thanks for the help. User error strikes again.
Like Post Reply
#5
It happens to all of us, glad you found it, Happy Boating
Like Post Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Charles C-Power Automatic A/B Selector Folkvord 7 389 08-31-2021, 08:24 AM
Last Post: Folkvord
  [Tiara Open] 2004 Open 32 Coastie57 1 263 07-07-2021, 06:12 PM
Last Post: Medicone
  [Tiara Open] 1994 3100 Open Number of Batteries Duke 2 270 05-14-2021, 09:51 AM
Last Post: ardoski14
  [Tiara Open] Access to cockpit wiring (1988 3300 open) cp4000 0 170 05-11-2021, 10:35 AM
Last Post: cp4000
  tuFUZ0cQ Shore power breakers/ surge protectors MichaelD 2 332 04-02-2021, 03:05 PM
Last Post: Harloo



Users browsing this thread:
1 Guest(s)

Troubleshooting raymarine power issues - 2010 3600 Open00