Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tiara Sovran Warning on EVC "Check Steering " and getting out of Limp Mode ?
#1
This weekend while  on a short ride about 30 minutes into  the outing the engine suddenly decreased in RPM from 2600 to idle .
Along with this we had the EVC warning "Check Steering Wheel "  I had never seen this before and looked into the manual for advice .  The only thing it said basically was to restart the engines and see if the problem persist .  We did so and the same warning happened, upon acceleration ( No more than 1500 RPM as we went into "Limp Mode " apparently )

My question to the forum is has anyone had this alarm and if so any solutions or ideas ? Secondly how do I get out of Limp Mode and clear the code ?

Thanks for any help .

2009 Tiara Sovran with Volvo 500 with IPS
Like Post Reply

#2
Anyone ever experience anything even similar to this?
Like Post Reply
#3
Not familiar with the IPS system but did you do some basic checks like fluids and linkage? I am sure that system will monitor things like that and if it gets low or maybe out of alignment it would possibly throw a code.
Sans Peur 2003 Tiara 50 Open
Like Post Reply
#4
Yes I did check fluids etc. I think through some due diligence I found a chafed wire behind the helm and I’m gonna need some help ( boat electrician )but I think I found the problem. Thanks for responding.
Like Post Reply
#5
(08-08-2021, 05:29 PM)Donaldjames Wrote: Yes I did check fluids etc. I think through some due diligence I found a chafed wire behind the helm and I’m gonna need some help ( boat electrician )but I think I found the problem. Thanks for responding.
Update:  After running the boat for several hours and putting at least 100 miles on her my EBC warning is back up. We have the technician coming out hopefully this week and I will update when we solve this condition. Very frustrating

(08-08-2021, 05:29 PM)Donaldjames Wrote: Yes I did check fluids etc. I think through some due diligence I found a chafed wire behind the helm and I’m gonna need some help ( boat electrician )but I think I found the problem. Thanks for responding.
Update:  After running the boat for several hours and putting at least 100 miles on her my EVC warning is back up. We have the technician coming out hopefully this week and I will update when we solve this condition. Very frustrating
Like Post Reply
#6
We have solved the EVC warnings , turns out we have a bad alternator which was causing low voltage condition which confused the EVC. We are replacing the ALTERNATOR , in the meantime we are running the generator which will operate the battery charger , this will keep more steady voltages . Hope this helps another forum member.
Cheers
[-] The following 1 user Likes Donaldjames's post:
Misdirection (09-11-2021)
Like Post Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Transmission fluid check stuart@seawisemarine.com 2 1,248 12-28-2019, 09:36 PM
Last Post: johnhesch
  IPS steering actuator fault Islandtime71 1 1,322 05-23-2019, 03:45 PM
Last Post: Navatech



Users browsing this thread:
1 Guest(s)

Warning on EVC "Check Steering " and getting out of Limp Mode ?00